In short
- CVE-2025-67715 is a MEDIUM (CVSS 4.3) vulnerability affecting weblate, weblate (weblate).
- Chance of exploitation in the next 30 days (EPSS): 0.27%, higher than 19.6% of all vulnerabilities.
- Fix: update to 5.15 or later.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.15
| 5.15
|
| weblate | < 5.15
| 5.15
|
Description
Impact
It was possible to retrieve user notification settings or list all users via API.
Patches
References
Thanks to Hector Ruiz Ruiz & NaxusAI for responsibly disclosing this vulnerability to Weblate.
NVD description
Weblate is a web based localization tool. In versions prior to 5.15, it was possible to retrieve user notification settings or list all users via API. Version 5.15 fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free