In short
- CVE-2025-67818 is a HIGH (CVSS 7.2) vulnerability affecting github.com/weaviate/weaviate, weaviate (weaviate).
- Chance of exploitation in the next 30 days (EPSS): 0.91%, higher than 60.0% of all vulnerabilities.
- Fix: update to 1.31.19, 1.32.16, 1.33.4, 1.30.20 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/weaviate/weaviate Go | ≥ 1.31.0-rc.0, < 1.31.19≥ 1.32.0-rc.0, < 1.32.16≥ 1.33.0-rc.0, < 1.33.4< 1.30.20
| 1.31.191.32.161.33.41.30.20
|
| weaviate | < 1.33.4
| 1.33.4
|
Description
An issue was discovered in Weaviate OSS before 1.33.4. An attacker with access to insert data into the database can craft an entry name with an absolute path (e.g., /etc/...) or use parent directory traversal (../../..) to escape the restore root when a backup is restored, potentially creating or overwriting files in arbitrary locations within the application's privilege scope.
NVD description
An issue was discovered in Weaviate OSS before 1.33.4. An attacker with access to insert data into the database can craft an entry name with an absolute path (e.g., /etc/...) or use parent directory traversal (../../..) to escape the restore root when a backup is restored, potentially creating or overwriting files in arbitrary locations within the application's privilege scope.
More vulnerabilities in github.com/weaviate/weaviate
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free