In short
- CVE-2025-68115 is a MEDIUM (CVSS 6.1) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 0.22%, higher than 12.4% of all vulnerabilities.
- Fix: update to 8.6.1, 9.1.0-alpha.3 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.0.0= 9.1.0< 8.6.1
| 8.6.1
|
| parse-server npm | ≥ 9.0.0, < 9.1.0-alpha.3< 8.6.1
| 9.1.0-alpha.38.6.1
|
Description
Impact
A Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages.
Patches
The patch escapes user controlled values that are inserted into the HTML pages.
Workarounds
None.
Resources
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 8.6.1 and 9.1.0-alpha.3, a Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages. The patch, available in versions 8.6.1 and 9.1.0-alpha.3, escapes user controlled values that are inserted into the HTML pages. No known workarounds are available.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free