In short
- CVE-2025-68129 is a HIGH (CVSS 7.5) vulnerability affecting auth0/auth0-php, auth0-php (auth0), laravel-auth0 (auth0).
- Chance of exploitation in the next 30 days (EPSS): 0.43%, higher than 36.8% of all vulnerabilities.
- Fix: update to 8.18.0, 7.20.0, 5.6.0, 5.5.0 or later.
Description
Description
In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.
Affected product and versions
Projects are affected if they meet the following preconditions:
- Applications using the Auth0-PHP SDK, versions between v8.0.0 and v8.17.0, or
- Applications using the following SDKs that rely on the Auth0-PHP SDK versions between v8.0.0 and v8.17.0:
- a. Auth0/symfony,
- b. Auth0/laravel-auth0,
- c. Auth0/wordpress.
Resolution
Upgrade Auth0/Auth0-PHP to version 8.18.0 or greater.
Acknowledgement
Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
NVD description
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. Projects are affected if they use Auth0-PHP SDK versions between v8.0.0 and v8.17.0, or applications using the following SDKs that rely on the Auth0-PHP SDK versions between v8.0.0 and v8.17.0: Auth0/symfony versions between 5.0.0 and 5.5.0, Auth0/laravel-auth0 versions between 7.0.0 and 7.19.0, and/or Auth0/wordpress plugin versions between 5.0.0-BETA0 and 5.4.0. Auth0/Auth0-PHP version 8.18.0 contains a patch for the issue.
More vulnerabilities in auth0/auth0-php
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free