In short
- CVE-2025-68150 is a MEDIUM (CVSS 6.5) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 0.33%, higher than 25.8% of all vulnerabilities.
- Fix: update to 8.6.2, 9.1.1-alpha.1 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.0.0= 9.1.0< 8.6.2
| 8.6.2
|
| parse-server npm | ≥ 9.0.0, < 9.1.1-alpha.1< 8.6.2
| 9.1.1-alpha.18.6.2
|
Description
Impact
The Instagram authentication adapter allows clients to specify a custom API URL via the apiURL parameter in authData. This enables SSRF attacks and possibly authentication bypass if malicious endpoints return fake responses to validate unauthorized users.
Patches
Fixed by hardcoding the Instagram Graph API URL https://graph.instagram.com and ignoring client-provided apiURL values.
Workarounds
None.
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.2 and 9.1.1-alpha.1, the Instagram authentication adapter allows clients to specify a custom API URL via the `apiURL` parameter in `authData`. This enables SSRF attacks and possibly authentication bypass if malicious endpoints return fake responses to validate unauthorized users. This is fixed in versions 8.6.2 and 9.1.1-alpha.1 by hardcoding the Instagram Graph API URL `https://graph.instagram.com` and ignoring client-provided `apiURL` values. No known workarounds are available.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free