In short
- CVE-2025-68279 is a MEDIUM (CVSS 6.5) vulnerability affecting weblate, weblate (weblate).
- Chance of exploitation in the next 30 days (EPSS): 0.41%, higher than 35.5% of all vulnerabilities.
- Fix: update to 5.15.1 or later.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.15.1
| 5.15.1
|
| weblate | < 5.15.1
| 5.15.1
|
Description
Impact
It was possible to read arbitrary files from the server file system using crafted symbolic links in the repository.
Resources
Thanks to Jason Marcello for responsible disclosure.
NVD description
Weblate is a web based localization tool. In versions prior to 5.15.1, it was possible to read arbitrary files from the server file system using crafted symbolic links in the repository. Version 5.15.1 fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free