In short
- CVE-2025-68675 is a HIGH (CVSS 7.5) vulnerability affecting apache-airflow, airflow (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.4% of all vulnerabilities.
- Fix: update to 3.1.6, 2.11.1 or later.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0b1, < 3.1.6< 2.11.1< 3.1.6
| 3.1.62.11.1
|
| airflow | < 3.1.6
| 3.1.6
|
Description
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields could be exposed.
Users are recommended to upgrade to 3.1.6 or later for Airflow 3, and 2.11.1 or later for Airflow 2 which fixes this issue.
NVD description
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields could be exposed.
Users are recommended to upgrade to 3.1.6 or later for Airflow 3, and 2.11.1 or later for Airflow 2 which fixes this issue
More vulnerabilities in apache-airflow
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free