In short
- CVE-2025-69199 is a MEDIUM (CVSS 6.5) vulnerability affecting github.com/pterodactyl/wings, wings (pterodactyl).
- Chance of exploitation in the next 30 days (EPSS): 0.30%, higher than 22.5% of all vulnerabilities.
- Fix: update to 1.12.0 or later.
Description
Summary
Websockets within wings lack proper rate limiting and throttling. As a result a malicious user can open a large number of connections and then request data through these sockets, causing an excessive volume of data over the network and overloading the host system memory and cpu.
Additionally, there is not a limit applied to the total size of messages being sent or received, allowing a malicious user to open thousands of websocket connections and then send massive volumes of information over the socket, overloading the host network, and causing increased CPU and memory load within Wings.
NVD description
Wings is the server control plane for Pterodactyl, a free, open-source game server management panel. Prior to version 1.12.0, websockets within wings lack proper rate limiting and throttling. As a result a malicious user can open a large number of connections and then request data through these sockets, causing an excessive volume of data over the network and overloading the host system memory and cpu. Additionally, there is not a limit applied to the total size of messages being sent or received, allowing a malicious user to open thousands of websocket connections and then send massive volumes of information over the socket, overloading the host network, and causing increased CPU and memory load within Wings. Version 1.12.0 patches the issue.
More vulnerabilities in github.com/pterodactyl/wings
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free