In short
- CVE-2025-69534 is a HIGH (CVSS 7.5) vulnerability affecting markdown, markdown (python-markdown).
- Chance of exploitation in the next 30 days (EPSS): 0.66%, higher than 52.0% of all vulnerabilities.
- Fix: update to 3.8.1 or later.
| Package | Affected versions | Patched versions |
|---|
| markdown PyPI | ≤ 3.8< 3.8.1
| 3.8.1
|
| markdown | = 3.8
| No fix yet |
Description
Python-Markdown version 3.8 contain a vulnerability where malformed HTML-like sequences can cause html.parser.HTMLParser to raise an unhandled AssertionError during Markdown parsing. Because Python-Markdown does not catch this exception, any application that processes attacker-controlled Markdown may crash. This enables remote, unauthenticated Denial of Service in web applications, documentation systems, CI/CD pipelines, and any service that renders untrusted Markdown. The issue was acknowledged by the vendor and fixed in version 3.8.1. This issue causes a remote Denial of Service in any application parsing untrusted Markdown, and can lead to Information Disclosure through uncaught exceptions.
NVD description
Python-Markdown version 3.8 contain a vulnerability where malformed HTML-like sequences can cause html.parser.HTMLParser to raise an unhandled AssertionError during Markdown parsing. Because Python-Markdown does not catch this exception, any application that processes attacker-controlled Markdown may crash. This enables remote, unauthenticated Denial of Service in web applications, documentation systems, CI/CD pipelines, and any service that renders untrusted Markdown. The issue was acknowledged by the vendor and fixed in version 3.8.1. This issue causes a remote Denial of Service in any application parsing untrusted Markdown, and can lead to Information Disclosure through uncaught exceptions.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free