In short
- CVE-2025-7031 is a MEDIUM (CVSS 5.3) vulnerability affecting drupal/config_pages_viewer, config pages viewer (config pages viewer project).
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 24.6% of all vulnerabilities.
- Fix: update to 1.0.4 or later.
Description
This module enables you to use config_pages as a content entity.
The module doesn't check permission or entity access before rendering config_pages content.
NVD description
Missing Authentication for Critical Function vulnerability in Drupal Config Pages Viewer allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Config Pages Viewer: from 0.0.0 before 1.0.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free