In short
- CVE-2025-70887 is a HIGH (CVSS 8.8) vulnerability affecting signify, signify (ralphje).
- Chance of exploitation in the next 30 days (EPSS): 0.35%, higher than 28.7% of all vulnerabilities.
- Fix: update to 0.9.2 or later.
| Package | Affected versions | Patched versions |
|---|
| signify PyPI | < 0.9.2
| 0.9.2
|
| signify | < 0.9.2
| 0.9.2
|
Description
An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components
NVD description
An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free