In short
- CVE-2025-70952 is a HIGH (CVSS 7.5) vulnerability affecting org.pf4j:pf4j, pf4j (pf4j project).
- Chance of exploitation in the next 30 days (EPSS): 0.87%, higher than 59.0% of all vulnerabilities.
- Fix: update to 3.14.1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.pf4j:pf4j Maven | < 3.14.1
| 3.14.1
|
| pf4j | < 3.14.1
| 3.14.1
|
Description
pf4j before 20c2f80 has a path traversal vulnerability in the extract() function of Unzip.java, where improper handling of zip entry names can allow directory traversal or Zip Slip attacks, due to a lack of proper path normalization and validation.
NVD description
pf4j before 20c2f80 has a path traversal vulnerability in the extract() function of Unzip.java, where improper handling of zip entry names can allow directory traversal or Zip Slip attacks, due to a lack of proper path normalization and validation.
More vulnerabilities in org.pf4j:pf4j
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free