In short
- CVE-2025-71329 is a HIGH (CVSS 7.5) vulnerability affecting image-size (image-size), image-size.
- Chance of exploitation in the next 30 days (EPSS): 0.43%, higher than 37.3% of all vulnerabilities.
- Fix: update to 2.0.3 or later.
| Package | Affected versions | Patched versions |
|---|
| image-size | ≥ 1.1.0, ≤ 1.2.1≥ 2.0.0, ≤ 2.0.2
| No fix yet |
| image-size npm | ≥ 1.2.0, < 2.0.3
| 2.0.3
|
Description
image-size through 2.0.2 contains a denial of service vulnerability that allows remote attackers to permanently block the Node.js event loop by supplying a specially crafted image buffer with a zero-valued size field in a recognized box-type. Attackers can trigger an infinite loop in the JXL or HEIF image parsers by providing a crafted image containing a box with a size of zero, causing the offset to never advance and permanently hanging the application.
NVD description
image-size through 2.0.2 contains a denial of service vulnerability that allows remote attackers to permanently block the Node.js event loop by supplying a specially crafted image buffer with a zero-valued size field in a recognized box-type. Attackers can trigger an infinite loop in the JXL or HEIF image parsers by providing a crafted image containing a box with a size of zero, causing the offset to never advance and permanently hanging the application.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free