In short
- CVE-2025-71408 is a HIGH (CVSS 7.8) vulnerability affecting nltk, nltk (nltk).
- Chance of exploitation in the next 30 days (EPSS): 0.27%, higher than 18.5% of all vulnerabilities.
- Fix: update to 3.9.3 or later.
| Package | Affected versions | Patched versions |
|---|
| nltk PyPI | < 3.9.3
| 3.9.3
|
| nltk | < 3.9.3
| 3.9.3
|
Description
NLTK (Natural Language Toolkit) before version 3.9.3 contains an eval injection vulnerability in the nltk.collocations module that allows an attacker who controls command-line arguments to execute arbitrary Python code. When collocations.py is invoked directly, the main block passes command-line arguments directly to eval() as suffixes of BigramAssocMeasures without allowlist validation or sanitization, enabling an attacker to supply a Python expression that escapes the intended attribute lookup and executes arbitrary code including OS commands via the os module.
NVD description
NLTK (Natural Language Toolkit) before version 3.9.3 contains an eval injection vulnerability in the nltk.collocations module that allows an attacker who controls command-line arguments to execute arbitrary Python code. When collocations.py is invoked directly, the __main__ block passes command-line arguments directly to eval() as suffixes of BigramAssocMeasures without allowlist validation or sanitization, enabling an attacker to supply a Python expression that escapes the intended attribute lookup and executes arbitrary code including OS commands via the os module.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free