In short
- CVE-2025-9092 is a LOW (CVSS 1.0) vulnerability affecting org.bouncycastle:bc-fips.
- Chance of exploitation in the next 30 days (EPSS): 0.15%, higher than 3.9% of all vulnerabilities.
- Fix: update to 2.1.1 or later.
Description
Uncontrolled Resource Consumption vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java - BC-FJA 2.1.0 bc-fips (API modules) allows Excessive Allocation. This vulnerability is associated with program files org.Bouncycastle.Crypto.Fips.NativeLoader.
This issue affects Bouncy Castle for Java - BC-FJA 2.1.0: from BC-FJA 2.1.0 through 2.1.0.
NVD description
Uncontrolled Resource Consumption vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java - BC-FJA 2.1.0 bc-fips (API modules) allows Excessive Allocation. This vulnerability is associated with program files org.Bouncycastle.Crypto.Fips.NativeLoader.
This issue affects Bouncy Castle for Java - BC-FJA 2.1.0: from BC-FJA 2.1.0 through 2.1.0.
More vulnerabilities in org.bouncycastle:bc-fips
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free