In short
- CVE-2025-9340 is a LOW (CVSS 0.0) vulnerability affecting org.bouncycastle:bc-fips.
- Chance of exploitation in the next 30 days (EPSS): 0.18%, higher than 7.3% of all vulnerabilities.
- Fix: update to 2.1.1 or later.
Description
Out-of-bounds Write vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java bc-fips on All (API modules). This vulnerability is associated with program files org/bouncycastle/jcajce/provider/BaseCipher.
This issue affects Bouncy Castle for Java: from BC-FJA 2.1.0 through 2.1.0.
NVD description
Out-of-bounds Write vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java bc-fips on All (API modules). This vulnerability is associated with program files org/bouncycastle/jcajce/provider/BaseCipher.
This issue affects Bouncy Castle for Java: from BC-FJA 2.1.0 through 2.1.0.
More vulnerabilities in org.bouncycastle:bc-fips
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free