| Package | Affected versions | Patched versions |
|---|---|---|
| dompurify | ≥ 2.5.3, ≤ 2.5.8≥ 3.1.3, ≤ 3.3.1 | |
| dompurify | ≥ 2.5.3, < 2.5.9≥ 3.1.3, < 3.3.2 | 2.5.93.3.2 |
DOMPurify 3.1.3 through 3.3.1 and 2.5.3 through 2.5.8, fixed in 2.5.9 and 3.3.2, contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting five missing rawtext elements (noscript, xmp, noembed, noframes, iframe) in the SAFE_FOR_XML regex. Attackers can include payloads like </noscript><img src=x onerror=alert(1)> in attribute values to execute JavaScript when sanitized output is placed inside these unprotected rawtext contexts.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free