In short
- CVE-2026-0846 is a HIGH (CVSS 7.5) vulnerability affecting nltk, nltk (nltk).
- Chance of exploitation in the next 30 days (EPSS): 0.55%, higher than 46.1% of all vulnerabilities.
- Fix: update to 3.9.3 or later.
| Package | Affected versions | Patched versions |
|---|
| nltk PyPI | ≤ 3.9.2< 3.9.3
| 3.9.3
|
| nltk | = 3.9.2
| No fix yet |
Description
A vulnerability in the filestring() function of the nltk.util module in nltk version 3.9.2 allows arbitrary file read due to improper validation of input paths. The function directly opens files specified by user input without sanitization, enabling attackers to access sensitive system files by providing absolute paths or traversal paths. This vulnerability can be exploited locally or remotely, particularly in scenarios where the function is used in web APIs or other interfaces that accept user-supplied input.
NVD description
A vulnerability in the `filestring()` function of the `nltk.util` module in nltk version 3.9.2 allows arbitrary file read due to improper validation of input paths. The function directly opens files specified by user input without sanitization, enabling attackers to access sensitive system files by providing absolute paths or traversal paths. This vulnerability can be exploited locally or remotely, particularly in scenarios where the function is used in web APIs or other interfaces that accept user-supplied input.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free