In short
- CVE-2026-100652 is a HIGH (CVSS 7.5) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.42%, higher than 36.3% of all vulnerabilities.
- Fix: update to 0.24.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | ≥ 0.22.0, < 0.24.0
| 0.24.0
|
| vllm | ≥ 0.22.0, < 0.24.0
| 0.24.0
|
Description
vLLM versions 0.22.0 through 0.23.0 fail to validate stop_token_ids against vocabulary bounds in Rust HTTP and gRPC frontends, allowing out-of-vocabulary token IDs to reach MinTokensLogitsProcessor. Attackers can submit requests with min_tokens greater than zero and out-of-vocabulary stop_token_ids to trigger CUDA tensor indexing failures that leave EngineCore in a fatal state requiring service restart.
NVD description
vLLM versions 0.22.0 through 0.23.0 fail to validate stop_token_ids against vocabulary bounds in Rust HTTP and gRPC frontends, allowing out-of-vocabulary token IDs to reach MinTokensLogitsProcessor. Attackers can submit requests with min_tokens greater than zero and out-of-vocabulary stop_token_ids to trigger CUDA tensor indexing failures that leave EngineCore in a fatal state requiring service restart.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free