In short
- CVE-2026-100840 is a HIGH (CVSS 7.8) vulnerability affecting monai, monai (project-monai).
- Chance of exploitation in the next 30 days (EPSS): 0.31%, higher than 24.2% of all vulnerabilities.
- Fix: update to 1.6.1rc0 or later.
| Package | Affected versions | Patched versions |
|---|
| monai PyPI | < 1.6.1rc0
| 1.6.1rc0
|
| monai | ≤ 1.6.0
| No fix yet |
Description
MONAI through 1.6.0 contains a remote code execution vulnerability in the bundle configuration engine that resolves target values to arbitrary importable callables without an allow list and passes $ expressions to Python eval(). Attackers can publish a malicious bundle with crafted configuration containing arbitrary code that executes when a victim loads the bundle using monai.bundle.load() or monai.bundle.run().
NVD description
MONAI through 1.6.0 contains a remote code execution vulnerability in the bundle configuration engine that resolves _target_ values to arbitrary importable callables without an allow list and passes $ expressions to Python eval(). Attackers can publish a malicious bundle with crafted configuration containing arbitrary code that executes when a victim loads the bundle using monai.bundle.load() or monai.bundle.run().
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free