In short
- CVE-2026-102994 is a HIGH (CVSS 7.5) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 27.6% of all vulnerabilities.
- Fix: update to 6.18.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.18.0
| 6.18.0
|
| pypdf | < 6.18.0
| 6.18.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires reading a PDF document with long indirect object headers, not terminated by whitespace.
Patches
This has been fixed in pypdf==6.18.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4055.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.18.0, a crafted PDF containing indirect-object identifiers or generation-number tokens that continue for a long time without whitespace can cause pypdf/_reader.py and pypdf/generic/_base.py to scan excessive input through read_until_whitespace, resulting in long runtimes and application unavailability. This issue is fixed in version 6.18.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free