In short
- CVE-2026-102999 is a HIGH (CVSS 7.5) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.35%, higher than 28.4% of all vulnerabilities.
- Fix: update to 6.19.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.19.0
| 6.19.0
|
| pypdf | < 6.19.0
| 6.19.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing the embedded files through the dictionary-based API.
Patches
This has been fixed in pypdf==6.19.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4081.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.19.0, a crafted PDF containing many embedded files can cause the dictionary-based attachments API in pypdf/_doc_common.py to reparse the full attachment list for each content lookup, producing repeated work and long runtimes when an application accesses the embedded-file mapping. This issue is fixed in version 6.19.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free