| Package | Affected versions | Patched versions |
|---|---|---|
| struts | ≥ 2.1.8, ≤ 2.3.37≥ 2.5.0, ≤ 2.5.33≥ 6.0.0, < 6.12.0≥ 7.0.0, < 7.4.0 | 6.12.07.4.0 |
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not use the REST plugin are not affected. This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free