In short
- CVE-2026-105861 is a HIGH (CVSS 8.2) vulnerability affecting payload (payloadcms), payload.
- Chance of exploitation in the next 30 days (EPSS): 0.13%, higher than 2.8% of all vulnerabilities.
- Fix: update to 3.90.0, 4.0.0-canary.34 or later.
| Package | Affected versions | Patched versions |
|---|
| payload | = 4.0.0≥ 3.0.0, < 3.90.0
| 3.90.0
|
| payload npm | ≥ 3.0.0, < 3.90.0≥ 4.0.0-canary.0, < 4.0.0-canary.34
| 3.90.04.0.0-canary.34
|
Description
Impact
Under certain external upload configurations, Payload could send authentication data to a destination that was not verified as trusted. If the affected request contained a valid session, this could expose that session to an unintended recipient.
You are affected if:
- You have enabled external URL-based upload retrieval, where authenticated requests can trigger it.
Patches
Payload now validates the destination before forwarding authentication data and reapplies that validation when a request changes destination.
Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
Workarounds
It is recommended to update all Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
If you cannot, a valid workaround exists:
- Disable external URL-based upload retrieval where practical.
- If you cannot disable it, configure the upload header filter to remove authentication data from outbound file requests.
- Restrict access to the affected upload functionality.
NVD description
Payload is a free and open source headless content management system. In versions after 3.0.0 and before 3.90.0, authenticated external URL-based upload retrieval can forward authentication data to a redirected destination that was not verified as trusted, potentially exposing a valid session to an unintended recipient. This issue is fixed in version 3.90.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free