In short
- CVE-2026-105863 is a CRITICAL (CVSS 9.4) vulnerability affecting payload (payloadcms), payload.
- Chance of exploitation in the next 30 days (EPSS): 0.38%, higher than 31.7% of all vulnerabilities.
- Fix: update to 3.90.0, 4.0.0-canary.34 or later.
| Package | Affected versions | Patched versions |
|---|
| payload | = 4.0.0≥ 3.0.0, < 3.90.0
| 3.90.0
|
| payload npm | ≥ 3.0.0, < 3.90.0≥ 4.0.0-canary.0, < 4.0.0-canary.34
| 3.90.04.0.0-canary.34
|
Description
Impact
Under certain field configurations, Payload could include unintended values in the authentication token issued at login.
You are affected if:
- You use an affected Payload version and have configured a custom field option that maps a field to a reserved authentication claim name.
Patches
Payload now restricts which field configuration options can influence the contents of the authentication token.
Users should upgrade payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
Workarounds
There is no complete workaround. Users should upgrade payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
NVD description
Payload is a free and open source headless content management system. In versions after 3.0.0 and before 3.90.0, a custom field option that maps a field to a reserved authentication claim name can place unintended values in the authentication token issued at login. This issue is fixed in version 3.90.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free