In short
- CVE-2026-105922 is a MEDIUM (CVSS 4.3) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.31%, higher than 24.0% of all vulnerabilities.
- Fix: update to 0.32.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | < 0.32.0
| 0.32.0
|
| vllm | ≤ 0.31.0
| No fix yet |
Description
A security flaw has been discovered in vllm-project vLLM up to 0.31.0. This impacts the function get_token_bin_counts_and_mask of the file vllm/model_executor/layers/utils.py of the component Penalty Handler. Performing a manipulation results in denial of service. Remote exploitation of the attack is possible. The exploit has been released to the public and may be used for attacks. The project was informed of the problem early through an issue report but has not responded yet.
NVD description
A security flaw has been discovered in vllm-project vLLM up to 0.31.0. This impacts the function get_token_bin_counts_and_mask of the file vllm/model_executor/layers/utils.py of the component Penalty Handler. Performing a manipulation results in denial of service. Remote exploitation of the attack is possible. The exploit has been released to the public and may be used for attacks. The project was informed of the problem early through an issue report but has not responded yet.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free