In short
- CVE-2026-106488 is a HIGH (CVSS 8.1) vulnerability affecting backstage (linuxfoundation), backstage/plugin-auth-backend-module-oidc-provider (linuxfoundation), @backstage/plugin-auth-backend-module-oidc-provider.
- Chance of exploitation in the next 30 days (EPSS): 0.28%, higher than 20.6% of all vulnerabilities.
- Fix: update to 1.54.6, 0.4.20 or later.
Description
Impact
Deployments using OIDC email-based identity resolution with a provider that permits unverified email addresses may allow an authenticated provider user to assume another catalog identity. This may grant access and permissions associated with that user. No direct availability impact is demonstrated.
Patches
Patched in @backstage/plugin-auth-backend-module-oidc-provider version 0.4.20.
Workarounds
- Disable email-based sign-in resolution for the OIDC provider, or require the identity provider to verify email addresses before allowing sign-in.
NVD description
Backstage is an open framework for building developer portals. Prior to 0.4.20, the @backstage/plugin-auth-backend-module-oidc-provider package is affected by improper authentication in the oidc provider. Deployments using OIDC email-based identity resolution with a provider that permits unverified email addresses may allow an authenticated provider user to assume another catalog identity. This may grant access and permissions associated with that user. No direct availability impact is demonstrated. This issue is fixed in version 0.4.20.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free