In short
- CVE-2026-106495 is a MEDIUM (CVSS 4.3) vulnerability affecting @backstage/backend-defaults.
- Chance of exploitation in the next 30 days (EPSS): 0.24%, higher than 15.0% of all vulnerabilities.
- Fix: update to 0.17.8 or later.
Description
Impact
An authenticated user could invoke actions that an operator had excluded through action configuration. Existing action permissions and downstream authorization remain enforced.
Patches
Patched in @backstage/backend-defaults version 0.17.8
Workarounds
Limit access to action invocation endpoints to trusted service callers until upgrading.
NVD description
Backstage is an open framework for building developer portals. Prior to 0.17.8, the @backstage/backend-defaults package is affected by improper access control in backend action invocation. An authenticated user could invoke actions that an operator had excluded through action configuration. Existing action permissions and downstream authorization remain enforced. This issue is fixed in version 0.17.8.
More vulnerabilities in @backstage/backend-defaults
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free