In short
- CVE-2026-110634 is a CRITICAL (CVSS 9.8) vulnerability affecting git-diff.
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.7% of all vulnerabilities.
- Fix: update to 2.0.7 or later.
| Package | Affected versions | Patched versions |
|---|
| git-diff npm | < 2.0.7
| 2.0.7
|
Description
git-diff before 2.0.7 contains an OS command injection vulnerability that allows attackers to execute shell commands by supplying crafted strings to the gitDiff API. Attackers who control a diffed document string can embed $(cmd) or backtick substitutions that shelljs.exec evaluates, running commands with Node.js process privileges.
NVD description
git-diff before 2.0.7 contains an OS command injection vulnerability that allows attackers to execute shell commands by supplying crafted strings to the gitDiff API. Attackers who control a diffed document string can embed $(cmd) or backtick substitutions that shelljs.exec evaluates, running commands with Node.js process privileges.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free