In short
- CVE-2026-113786 is a LOW (CVSS 2.3) vulnerability affecting pypdf.
- Chance of exploitation in the next 30 days (EPSS): 0.38%, higher than 31.5% of all vulnerabilities.
- Fix: update to 6.21.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.21.1
| 6.21.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to arbitrary image parsers being called. This requires loading an image which claims to use the /DCTDecode filter (JPEG data).
Users which do not have the optional Pillow dependency installed in their environment are not affected.
Patches
This has been fixed in pypdf==6.21.1.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4222.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.1, an attacker can craft a PDF containing image data labeled with the /DCTDecode filter that causes Pillow to select and invoke an unintended image parser when the image is loaded. Environments without the optional Pillow dependency are not affected. This issue is fixed in version 6.21.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free