In short
- CVE-2026-113790 is a MEDIUM (CVSS 6.0) vulnerability affecting pypdf.
- Chance of exploitation in the next 30 days (EPSS): 0.39%, higher than 33.3% of all vulnerabilities.
- Fix: update to 6.21.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.21.0
| 6.21.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing arrays and/or dictionaries with lots of elements.
Patches
This has been fixed in pypdf==6.21.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4218.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.0, an attacker can craft a PDF containing arrays or dictionaries with many elements, causing parsing to consume large amounts of memory. This issue is fixed in version 6.21.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free