In short
- CVE-2026-113794 is a MEDIUM (CVSS 6.0) vulnerability affecting pypdf.
- Chance of exploitation in the next 30 days (EPSS): 0.47%, higher than 40.3% of all vulnerabilities.
- Fix: update to 6.20.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.20.0
| 6.20.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires an incomplete file which ends inside the xref table.
Patches
This has been fixed in pypdf==6.20.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4170.
Notes
This has been reported through both the secure channel and as a public issue at #4169.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.20.0, an attacker can craft an incomplete PDF that ends inside a standard cross-reference table, causing pypdf to mishandle the unexpected end of file and enter an infinite loop. This issue is fixed in version 6.20.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free