In short
- CVE-2026-115572 is a HIGH (CVSS 7.1) vulnerability affecting pypdf.
- Chance of exploitation in the next 30 days (EPSS): 0.38%, higher than 31.5% of all vulnerabilities.
- Fix: update to 6.21.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.21.2
| 6.21.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires loading relevant parts of a file (like their pages) where the same, but non-existent indirect object is referenced multiple times.
Patches
This has been fixed in pypdf==6.21.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4240.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF that repeatedly references the same nonexistent indirect object, causing relevant file parts such as pages to trigger repeated full-file recovery loads and long runtimes when accessed. This issue is fixed in version 6.21.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free