In short
- CVE-2026-115580 is a HIGH (CVSS 7.1) vulnerability affecting pypdf.
- Chance of exploitation in the next 30 days (EPSS): 0.41%, higher than 35.2% of all vulnerabilities.
- Fix: update to 6.21.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.21.2
| 6.21.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires opening a file with large/wrong upper limits in the xref table.
Patches
This has been fixed in pypdf==6.21.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4239.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF with a standard cross-reference table whose declared entry count exceeds what the file can contain, causing excessive processing and long runtimes when the file is opened. This issue is fixed in version 6.21.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free