In short
- CVE-2026-116176 is a HIGH (CVSS 8.2) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 24.8% of all vulnerabilities.
- Fix: update to 0.24.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | ≥ 0.9.2, < 0.24.0
| 0.24.0
|
| vllm | ≥ 0.9.2, < 0.24.0
| 0.24.0
|
Description
vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the X-Request-Id header. Attackers can make a P2pNcclConnector prefill worker ZMQ-connect to an attacker host, leaking the NCCL unique_id and KV-cache tensors or blocking the worker.
NVD description
vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the X-Request-Id header. Attackers can make a P2pNcclConnector prefill worker ZMQ-connect to an attacker host, leaking the NCCL unique_id and KV-cache tensors or blocking the worker.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free