In short
- CVE-2026-116177 is a HIGH (CVSS 7.5) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.29%, higher than 21.7% of all vulnerabilities.
- Fix: update to 0.25.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | ≥ 0.10.2, < 0.25.0
| 0.25.0
|
| vllm | ≥ 0.10.2, < 0.25.0
| 0.25.0
|
Description
vLLM from 0.10.2 before 0.25.0 contains an uncontrolled resource consumption vulnerability that allows unauthenticated attackers to exhaust memory because the Nemotron-VL processors globally set Image.MAX_IMAGE_PIXELS to None. Attackers can submit a pathological decompression-bomb image to /v1/chat/completions to OOM-kill the worker and deny service to co-tenants.
NVD description
vLLM from 0.10.2 before 0.25.0 contains an uncontrolled resource consumption vulnerability that allows unauthenticated attackers to exhaust memory because the Nemotron-VL processors globally set Image.MAX_IMAGE_PIXELS to None. Attackers can submit a pathological decompression-bomb image to /v1/chat/completions to OOM-kill the worker and deny service to co-tenants.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free