In short
- CVE-2026-118549 is a HIGH (CVSS 7.1) vulnerability affecting drupal/ai.
- Chance of exploitation in the next 30 days (EPSS): 0.19%, higher than 8.8% of all vulnerabilities.
- Fix: update to 1.5.2, 1.4.11 or later.
| Package | Affected versions | Patched versions |
|---|
| drupal/ai Packagist:https://packages.drupal.org/8 | ≥ 1.5.0, < 1.5.2< 1.4.11
| 1.5.21.4.11
|
Description
This AI module enables you to interact with AI providers. It has a service that helps any consumer of the module to stop cross site scripting elements from appearing.
The module does not sufficiently validate Markdown links under certain conditions, potentially allowing cross-site scripting (XSS).
NVD description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal AI (Artificial Intelligence) allows Cross-Site Scripting (XSS). This issue affects AI (Artificial Intelligence) versions: from 0.0.0 to 1.4.11, from 1.5.0 to 1.5.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free