In short
- CVE-2026-12644 is a MEDIUM (CVSS 5.3) vulnerability affecting ts-deepmerge.
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.5% of all vulnerabilities.
- Fix: update to 8.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ts-deepmerge npm | < 8.0.0
| 8.0.0
|
Description
Versions of the package ts-deepmerge before 8.0.0 are vulnerable to Uncaught Exception due to the improper handling of built-in Object.prototype methods (such as toString, valueOf). When user-controlled input contains these keys with non-function values, the resulting merged object becomes broken — any string context operation throws a TypeError, crashing the application.
NVD description
Versions of the package ts-deepmerge before 8.0.0 are vulnerable to Uncaught Exception due to the improper handling of built-in Object.prototype methods (such as toString, valueOf). When user-controlled input contains these keys with non-function values, the resulting merged object becomes broken — any string context operation throws a TypeError, crashing the application.
More vulnerabilities in ts-deepmerge
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free