| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/containers/podman | all versions | |
| github.com/containers/podman/v2 | all versions | |
| github.com/containers/podman/v3 | all versions | |
| github.com/containers/podman/v4 | all versions | |
| github.com/containers/podman/v5 | ≥ 5.7.0, < 5.8.6 | 5.8.6 |
When running podman quadlet install --replace to replace a Quadlet file, if the original Quadlet is larger than the new Quadlet, the file would not be truncated and content from the original would be preserved. There is no risk of information leakage as the user already had access to the Quadlet in order to replace it, and in most cases, this would only lead to invalid Quadlet files (see ). However, security-related options from the end of the old Quadlet could be included in the new Quadlet, and if the truncation resulted in a valid Quadlet file, this could result in undesirable behavior. For example, running to remove a single line from the end of a Quadlet - including security-sensitive content, like - will fail, and the option will continue to be used. Further, with Volume Quadlets, this can include additional mounts which can cause content to be unintentionally exposed into containers. If, later, the image is updated then compromised content might be leaked to an attacker.
podman quadlet install --replaceAddCapabilityFirst introduced in commit 0ea4eaee70b7458bcc99d875529761faf5172651 with podman 5.7.0
a38a9b7d20915c55e6f3c451101ae72d6da33742 (fixed in 6.0.0)
d3adfdeec7d5c9eee5a6978df3bee62a866c958d d4fe9154ec6e32a02d5fcd096c4a27c38f2040f4 (for v5.8 branch, fixed in 5.8.6)
Manually copy the quadlet files to the quadlet directory.
Podman thanks Christopher Lusk [email protected] (North Echo Security Research) for reporting the security impact of this problem.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free