In short
- CVE-2026-2033 is a HIGH (CVSS 7.3) vulnerability affecting mlflow.
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 79.1% of all vulnerabilities.
- Fix: update to 3.8.0rc0 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 3.8.0rc0
| 3.8.0rc0
|
Description
MLflow Tracking Server Artifact Handler Directory Traversal Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of MLflow Tracking Server. Authentication is not required to exploit this vulnerability.
The specific flaw exists within the handling of artifact file paths. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to execute code in the context of the service account.
NVD description
MLflow Tracking Server Artifact Handler Directory Traversal Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of MLflow Tracking Server. Authentication is not required to exploit this vulnerability.
The specific flaw exists within the handling of artifact file paths. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-26649.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free