In short
- CVE-2026-24126 is a CRITICAL (CVSS 9.1) vulnerability affecting weblate, weblate (weblate).
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.1% of all vulnerabilities.
- Fix: update to 5.16, 5.16.0 or later.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.16< 5.16.0
| 5.165.16.0
|
| weblate | < 5.16
| 5.16
|
Description
Impact
The SSH management console did not validate the passed input while adding the SSH host key, which could lead to an argument injection to ssh-add.
Patches
Workarounds
Properly limit access to the management console.
References
This issue was reported to us by alexb_616 via HackerOne.
NVD description
Weblate is a web based localization tool. Prior to 5.16.0, the SSH management console did not validate the passed input while adding the SSH host key, which could lead to an argument injection to `ssh-add`. Version 5.16.0 fixes the issue. As a workaround, properly limit access to the management console.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free