| Package | Affected versions | Patched versions |
|---|---|---|
| openmq | ≤ 6.5.1 |
An unsafe parsing of OpenMQ's configuration in OpenMQ versions <6.5.2 and <6.9.0, allows a remote attacker to read arbitrary files from a MQ Broker's server. A full exploitation could read unauthorized files of the OpenMQ’s host OS. In some scenarios RCE could be achieved. This is fixed in OpenMQ 6.5.2, 6.9.0, and in GlassFish 7.0.26, 7.1.1, and 8.0.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free