In short
- CVE-2026-24688 is a MEDIUM (CVSS 4.3) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.45%, higher than 38.7% of all vulnerabilities.
- Fix: update to 6.6.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.6.2
| 6.6.2
|
| pypdf | < 6.6.2
| 6.6.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires accessing the outlines/bookmarks.
Patches
This has been fixed in pypdf 6.6.2.
Workarounds
If projects cannot upgrade yet, consider applying the changes from PR #3610.
NVD description
pypdf is a free and open-source pure-python PDF library. An attacker who uses an infinite loop vulnerability that is present in versions prior to 6.6.2 can craft a PDF which leads to an infinite loop. This requires accessing the outlines/bookmarks. This has been fixed in pypdf 6.6.2. If projects cannot upgrade yet, consider applying the changes from PR #3610 manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free