In short
- CVE-2026-25759 is a HIGH (CVSS 8.7) vulnerability affecting statamic/cms, statamic (statamic).
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 27.3% of all vulnerabilities.
- Fix: update to 6.2.3 or later.
| Package | Affected versions | Patched versions |
|---|
| statamic/cms Packagist | ≥ 6.0.0, < 6.2.3
| 6.2.3
|
| statamic | ≥ 6.0.0, < 6.2.3
| 6.2.3
|
Description
Impact
Stored XSS vulnerability in content titles allow authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users.
Malicious user must have an account with control panel access and content creation permissions.
This vulnerability can be exploited to allow super admin accounts to be created.
Patches
This has been fixed in 6.2.3.
NVD description
Statmatic is a Laravel and Git powered content management system (CMS). From 6.0.0 to before 6.2.3, a stored XSS vulnerability in content titles allows authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. Malicious user must have an account with control panel access and content creation permissions. This vulnerability can be exploited to allow super admin accounts to be created. This has been fixed in 6.2.3.
More vulnerabilities in statamic/cms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free