In short
- CVE-2026-25958 is a HIGH (CVSS 7.7) vulnerability affecting cube.js (cube), @cubejs-backend/server-core.
- Chance of exploitation in the next 30 days (EPSS): 0.38%, higher than 32.4% of all vulnerabilities.
- Fix: update to 1.0.14, 1.4.2, 1.5.13 or later.
| Package | Affected versions | Patched versions |
|---|
| cube.js | ≥ 0.27.19, < 1.0.14≥ 1.1.0, < 1.4.2≥ 1.5.0, < 1.5.13
| 1.0.141.4.21.5.13
|
| @cubejs-backend/server-core npm | ≥ 0.27.19, < 1.0.14≥ 1.1.0, < 1.4.2≥ 1.5.0, < 1.5.13
| 1.0.141.4.21.5.13
|
Description
Impact
It is possible to make a specially crafted request with a valid API token that leads to privilege escalation.
Affected Versions:
≥= 0.27.19
Mitigation:
Upgrade to a patched version:
- 1.5.13 and later (regular release)
- 1.4.2 (active LTS release)
- 1.0.14 (end-of-life LTS release)
References
The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.
NVD description
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free