In short
- CVE-2026-2635 is a HIGH (CVSS 7.3) vulnerability affecting mlflow.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.0% of all vulnerabilities.
- Fix: update to 3.8.0rc0 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 3.8.0rc0
| 3.8.0rc0
|
Description
This vulnerability allows remote attackers to bypass authentication on affected installations of MLflow. Authentication is not required to exploit this vulnerability.
The specific flaw exists within the basic_auth.ini file. The file contains hard-coded default credentials. An attacker can leverage this vulnerability to bypass authentication and execute arbitrary code in the context of the administrator.
NVD description
MLflow Use of Default Password Authentication Bypass Vulnerability. This vulnerability allows remote attackers to bypass authentication on affected installations of MLflow. Authentication is not required to exploit this vulnerability.
The specific flaw exists within the basic_auth.ini file. The file contains hard-coded default credentials. An attacker can leverage this vulnerability to bypass authentication and execute arbitrary code in the context of the administrator. Was ZDI-CAN-28256.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free