In short
- CVE-2026-2651 is a CRITICAL (CVSS 9.0) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 28.1% of all vulnerabilities.
- Fix: update to 3.10.0, 3.11.0rc0 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 3.10.0< 3.11.0rc0
| 3.10.03.11.0rc0
|
| mlflow | ≤ 3.10.1
| No fix yet |
Description
A vulnerability in MLflow versions <=3.10.1.dev0 allows unauthorized access to multipart upload (MPU) endpoints when the --serve-artifacts mode is enabled. The authorization logic does not enforce resource-level permission checks for /mlflow-artifacts/mpu/* endpoints, enabling attackers to overwrite artifacts belonging to other users. This can lead to unauthorized cross-user writes, model supply chain poisoning, and arbitrary code execution when compromised models are loaded. The issue is resolved in version 3.10.0.
NVD description
A vulnerability in MLflow versions <=3.10.1.dev0 allows unauthorized access to multipart upload (MPU) endpoints when the `--serve-artifacts` mode is enabled. The authorization logic does not enforce resource-level permission checks for `/mlflow-artifacts/mpu/*` endpoints, enabling attackers to overwrite artifacts belonging to other users. This can lead to unauthorized cross-user writes, model supply chain poisoning, and arbitrary code execution when compromised models are loaded. The issue is resolved in version 3.10.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free