In short
- CVE-2026-27026 is a MEDIUM (CVSS 5.5) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.19%, higher than 8.8% of all vulnerabilities.
- Fix: update to 6.7.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.1
| 6.7.1
|
| pypdf | < 6.7.1
| 6.7.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires a malformed /FlateDecode stream, where the byte-by-byte decompression is used.
Patches
This has been fixed in pypdf==6.7.1.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3644.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.7.1, an attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires a malformed /FlateDecode stream, where the byte-by-byte decompression is used. This vulnerability is fixed in 6.7.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free