In short
- CVE-2026-27901 is a MEDIUM (CVSS 6.1) vulnerability affecting svelte (svelte), svelte.
- Chance of exploitation in the next 30 days (EPSS): 0.26%, higher than 17.4% of all vulnerabilities.
- Fix: update to 5.53.5 or later.
| Package | Affected versions | Patched versions |
|---|
| svelte | = 5.53.5< 5.53.5
| 5.53.5
|
| svelte npm | < 5.53.5
| 5.53.5
|
Description
The contents of bind:innerText and bind:textContent on contenteditable elements were not properly escaped. This could enable HTML injection and Cross-site Scripting (XSS) if rendering untrusted data as the binding's initial value on the server.
NVD description
Svelte performance oriented web framework. Prior to version 5.53.5, the contents of `bind:innerText` and `bind:textContent` on `contenteditable` elements were not properly escaped. This could enable HTML injection and Cross-Site Scripting (XSS) if rendering untrusted data as the binding's initial value on the server. Version 5.53.5 fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free