In short
- CVE-2026-28351 is a MEDIUM (CVSS 5.3) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.48%, higher than 41.4% of all vulnerabilities.
- Fix: update to 6.7.4 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.4
| 6.7.4
|
| pypdf | < 6.7.4
| 6.7.4
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream using the RunLengthDecode filter.
Patches
This has been fixed in pypdf==6.7.4.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3664.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.7.4, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream using the RunLengthDecode filter. This has been fixed in pypdf 6.7.4. As a workaround, consider applying the changes from PR #3664.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free